You are here: System Requirements > Browser Requirements

Browser Requirements

DataSite v7 supports Microsoft Internet Explorer (Windows only), Mozilla Firefox, Apple Safari (Mac only), and Google Chrome browsers.

DataSite's System Requirements Check runs automatically after you log in. If your system does not meet minimum browser requirements, an alert on the bottom of your DataSite Dashboard will notify you that minimum requirements have not been met. Click on the Details link to learn about which browser you are using and to find links to Help content with steps for upgrading your browser.

If you prefer to run a check on your system prior to logging in, click on the System Requirements Check link on the Login page. A window will open that identifies your browser.

You may be able to continue using DataSite without meeting minimum browser requirements, but you may experience loss of functionality.

Internet Explorer (Windows only)

Internet Explorer 8.0 or higher is required for optimal DataSite performance.

To upgrade to the most recent version of Internet Explorer, visit http://www.microsoft.com/windows/internet-explorer/

Firefox

Firefox v27 or higher is required for optimal DataSite performance.

To upgrade to the most recent version of Firefox, visit http://www.mozilla.org

Chrome (Windows only)

Chrome 32.0 or higher is required for optimal DataSite performance.

To upgrade to the most recent version of Chrome, visit http://www.google.com/chrome

Safari

Safari 7 or higher is required for optimal DataSite performance.

To upgrade to the most recent version of Safari, visit http://www.apple.com/safari/